解决Warning: scandir() has been disabled for security reasons in..

今天将wordpress升级到最新版本,结果出现了网站主题不能编辑的问题。出现如下提示:Warning: scandir() has been disabled for security reasons in..class-wp-theme.php。起先以为class-wp-theme.php是不是出现问题,后来仔细一看英文,明白了。

解决办法: vi/usr/local/php/etc/php.ini

找到php.ini文件,找到disable_functions那一行去掉scandir函数即可。

/etc/init.d/php-fpm restart 重启php-fpm。